Twitter Ads partial outage
Incident Report for Swydo
Resolved
We are glad to announce that the issue with Twitter Ads has been resolved. It started June 20th, 2023 around 4PM (GMT+2) and impacted most of our Twitter Ads users.

We are truly sorry for any inconvenience this may have caused.

Thanks again for your patience during this disruption.

Your Swydo Team!
Posted Jun 22, 2023 - 16:23 CEST
Identified
We’re currently experiencing a service outage for Twitter Ads, which needs to be resolved on their end. Our team is in close contact with their technical team to get it fixed as soon as possible.

We’ve determined that Twitter is returning internal errors when we try to retrieve data from their platform, which is resulting in "Unfortunately something went wrong" or "Twitter Ads encountered an unknown error fetching the data." errors showing for Twitter Ads widgets. Most Twitter Ads users may be affected.

At Swydo we’re committed to providing the best possible service. Rest assured we are doing our best to get Twitter Ads restored at the earliest. We’ll give you an update once we have more information.

Thank you for your patience.

Your Swydo Team!
Posted Jun 21, 2023 - 15:52 CEST
This incident affected: Application, Integrations, and API.